import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\\\)\n"
+ "(?<code_all>\n"
+ " (?<code_start>\\`{1,})\n"
+ " (?<code_content>.+?)\n"
+ " (?<!`)\n"
+ " \\g\\{code_start\\}\n"
+ " (?!`)\n"
+ ")\n";
final String string = "foo `bar`";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}