$re = '/(?<!\\\\)
(?<code_all>
(?<code_start>\`{1,})
(?<code_content>.+?)
(?<!`)
\g{code_start}
(?!`)
)
/x';
$str = 'foo `bar`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);