#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)"""([^"]*?xyz)?.*?""""
Local $sString = """"" & @CRLF & _
"blah blah" & @CRLF & _
"blah" & @CRLF & _
"xyz" & @CRLF & _
"blah blah" & @CRLF & _
""""" & @CRLF & _
"" & @CRLF & _
""""" & @CRLF & _
" blah blah blah" & @CRLF & _
" blah" & @CRLF & _
""""" & @CRLF & _
"" & @CRLF & _
" # xyz" & @CRLF & _
" " & @CRLF & _
" def foo(self):" & @CRLF & _
""""" & @CRLF & _
"blah" & @CRLF & _
""""" & @CRLF & _
"" & @CRLF & _
"-----------------" & @CRLF & _
"no xyz no" & @CRLF & _
"" & @CRLF & _
""""" & @CRLF & _
"yes xyz yes" & @CRLF & _
"""""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")