package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)"""([^"]*?xyz)?.*?"""`)
var str = `"""
blah blah
blah
xyz
blah blah
"""
"""
blah blah blah
blah
"""
# xyz
def foo(self):
"""
blah
"""
-----------------
no xyz no
"""
yes xyz yes
"""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}