// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?ms)"""([^"]*?xyz)?.*?""""#).unwrap();
let string = "\"\"\"
blah blah
blah
xyz
blah blah
\"\"\"
\"\"\"
blah blah blah
blah
\"\"\"
# xyz
def foo(self):
\"\"\"
blah
\"\"\"
-----------------
no xyz no
\"\"\"
yes xyz yes
\"\"\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}