import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ms)\"\"\"([^\"]*?xyz)?.*?\"\"\"";
final String string = "\"\"\"\n"
+ "blah blah\n"
+ "blah\n"
+ "xyz\n"
+ "blah blah\n"
+ "\"\"\"\n\n"
+ "\"\"\"\n"
+ " blah blah blah\n"
+ " blah\n"
+ "\"\"\"\n\n"
+ " # xyz\n"
+ " \n"
+ " def foo(self):\n"
+ "\"\"\"\n"
+ "blah\n"
+ "\"\"\"\n\n"
+ "-----------------\n"
+ "no xyz no\n\n"
+ "\"\"\"\n"
+ "yes xyz yes\n"
+ "\"\"\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}