import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\|\\s+\\d+:\\d+:\\d+\\s+\\|\\s+(failed|passed)\\s+\\|\\s+([^\\|]+)\\s+\\|\\s+(.*)$";
final String string = "[ i ] PROCESS SUITES/TESTS RESULTS ...\n"
+ "-------------------------------------------------------------------------------\n"
+ " Suite: acceptance_ui_account (1 tests)\n"
+ "-------------------------------------------------------------------------------\n"
+ " failed: 1\n"
+ "-------------------------------------------------------------------------------\n"
+ "| 00:00:05 | failed | User can log in | user/login/alice.yml\n"
+ "| 00:00:12 | passed | User can log in | user/login/bob.yml\n"
+ "| 00:00:18 | passed | User can log in | user/login/charlie.yml\n"
+ "-------------------------------------------------------------------------------\n"
+ " Suite start time : 12:41:09\n"
+ " Suite end time : 12:41:27\n"
+ " Suite elapsed time: 00:00:18\n"
+ "-------------------------------------------------------------------------------\n"
+ "[ ! ] Failed tests list was stored in 'acceptance_ui_account' suite.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}