const regex = /\|\s+\d+:\d+:\d+\s+\|\s+(failed|passed)\s+\|\s+([^\|]+)\s+\|\s+(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|\\s+\\d+:\\d+:\\d+\\s+\\|\\s+(failed|passed)\\s+\\|\\s+([^\\|]+)\\s+\\|\\s+(.*)$', 'gm')
const str = `[ i ] PROCESS SUITES/TESTS RESULTS ...
-------------------------------------------------------------------------------
Suite: acceptance_ui_account (1 tests)
-------------------------------------------------------------------------------
failed: 1
-------------------------------------------------------------------------------
| 00:00:05 | failed | User can log in | user/login/alice.yml
| 00:00:12 | passed | User can log in | user/login/bob.yml
| 00:00:18 | passed | User can log in | user/login/charlie.yml
-------------------------------------------------------------------------------
Suite start time : 12:41:09
Suite end time : 12:41:27
Suite elapsed time: 00:00:18
-------------------------------------------------------------------------------
[ ! ] Failed tests list was stored in 'acceptance_ui_account' suite.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);