// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\|\s+\d+:\d+:\d+\s+\|\s+(failed|passed)\s+\|\s+([^\|]+)\s+\|\s+(.*)$").unwrap();
let string = "[ i ] PROCESS SUITES/TESTS RESULTS ...
-------------------------------------------------------------------------------
Suite: acceptance_ui_account (1 tests)
-------------------------------------------------------------------------------
failed: 1
-------------------------------------------------------------------------------
| 00:00:05 | failed | User can log in | user/login/alice.yml
| 00:00:12 | passed | User can log in | user/login/bob.yml
| 00:00:18 | passed | User can log in | user/login/charlie.yml
-------------------------------------------------------------------------------
Suite start time : 12:41:09
Suite end time : 12:41:27
Suite elapsed time: 00:00:18
-------------------------------------------------------------------------------
[ ! ] Failed tests list was stored in 'acceptance_ui_account' suite.";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}