import Foundation
let pattern = #"\|\s+\d+:\d+:\d+\s+\|\s+(failed|passed)\s+\|\s+([^\|]+)\s+\|\s+(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[ i ] PROCESS SUITES/TESTS RESULTS ...
-------------------------------------------------------------------------------
Suite: acceptance_ui_account (1 tests)
-------------------------------------------------------------------------------
failed: 1
-------------------------------------------------------------------------------
| 00:00:05 | failed | User can log in | user/login/alice.yml
| 00:00:12 | passed | User can log in | user/login/bob.yml
| 00:00:18 | passed | User can log in | user/login/charlie.yml
-------------------------------------------------------------------------------
Suite start time : 12:41:09
Suite end time : 12:41:27
Suite elapsed time: 00:00:18
-------------------------------------------------------------------------------
[ ! ] Failed tests list was stored in 'acceptance_ui_account' suite.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)