using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d*(0)1[23456789] | (0|1)2[3456789] | (0|1|2)3[456789] |(0|1|2|3)4[56789] | (0|1|2|3|4)5[6789] | (0|1|2|3|4|5)6[789] |(0|1|2|3|4|5|6)7[89] | (0|1|2|3|4|5|6|7)8(9)\d*$";
string input = @"123
9876456000
123456789
246
91370
3456
111
415263
xyz123xyz";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}