import re
regex = re.compile(r"""
^\d*(0)1[23456789] | (0|1)2[3456789] | (0|1|2)3[456789] |(0|1|2|3)4[56789] | (0|1|2|3|4)5[6789] | (0|1|2|3|4|5)6[789] |(0|1|2|3|4|5|6)7[89] | (0|1|2|3|4|5|6|7)8(9)\d*$
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("123\n"
"9876456000\n"
"123456789\n"
"246\n"
"91370\n"
"3456\n\n"
"111\n"
"415263\n"
"xyz123xyz")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")