use strict;
my $str = '13,4
5,66876876
13,4-15,6
4-5
5
45
34,534
13,7-14
14-15,6
14-15,67
1,236
14,5-15
15-16,5
4,5-16,76
100,4
100,45
100,45-100,4
100,4-100,54
100,5-123323,5';
my $regex = qr/^\d+((,\d)?(-(\d+)?(,\d)?)?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}