import re
regex = re.compile(r"^\d+((,\d)?(-(\d+)?(,\d)?)?)?$", flags=re.MULTILINE)
test_str = ("13,4\n"
"5,66876876\n"
"13,4-15,6\n"
"4-5\n"
"5\n"
"45\n"
"34,534\n"
"13,7-14\n"
"14-15,6\n"
"14-15,67\n"
"1,236\n"
"14,5-15\n"
"15-16,5\n"
"4,5-16,76\n"
"100,4\n"
"100,45\n"
"100,45-100,4\n"
"100,4-100,54\n"
"100,5-123323,5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")