package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\/(?:3[0-2]|[12]*\d),)*(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\/(?:3[0-2]|[12]*\d)$`)
var str = `192.168.1.1/0,255.255.255.255/32,10.10.10.10/24,0.0.0.0/24
192.168.1.1/32
192.168.1.1/0
192.168.1.1/33
192.168.1.1/01
,192.168.1.1/24
192.168.1.1/24,
192.168.1.1
/32`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}