package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<agroup>\|a(?<title>.+)){0,1}(?<bgroup>\|b(?<subtitle>.+)){0,1}(?<cgroup>\|c(?<author_info>.+)){0,1}`)
var str = `|a První kroky z deprese / |c Sue Atkinson ; [z angličtiny přeložil Jindřich Kotvrda]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}