const regex = /(?<agroup>\|a(?<title>.+)){0,1}(?<bgroup>\|b(?<subtitle>.+)){0,1}(?<cgroup>\|c(?<author_info>.+)){0,1}/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<agroup>\\|a(?<title>.+)){0,1}(?<bgroup>\\|b(?<subtitle>.+)){0,1}(?<cgroup>\\|c(?<author_info>.+)){0,1}', 'u')
const str = `|a První kroky z deprese / |c Sue Atkinson ; [z angličtiny přeložil Jindřich Kotvrda]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}