re = /(?<agroup>\|a(?<title>.+)){0,1}(?<bgroup>\|b(?<subtitle>.+)){0,1}(?<cgroup>\|c(?<author_info>.+)){0,1}/
str = '|a První kroky z deprese / |c Sue Atkinson ; [z angličtiny přeložil Jindřich Kotvrda]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end