// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(?<agroup>\|a(?<title>.+)){0,1}(?<bgroup>\|b(?<subtitle>.+)){0,1}(?<cgroup>\|c(?<author_info>.+)){0,1}").unwrap();
let string = "|a První kroky z deprese / |c Sue Atkinson ; [z angličtiny přeložil Jindřich Kotvrda]";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}