using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{0,}(\.{0,1}|,{0,1})\d{1,2}";
string input = @"
123,12333333333333,33333333333";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}