$re = '/\d{0,}(\.{0,1}|,{0,1})\d{1,2}/';
$str = '
123,12333333333333,33333333333';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);