const regex = /\d{0,}(\.{0,1}|,{0,1})\d{1,2}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{0,}(\\.{0,1}|,{0,1})\\d{1,2}', '')
const str = `
123,12333333333333,33333333333`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}