$re = '/\[[^\]\[]*\.png[^\]\[]*\]/m';
$str = '[yo.png.loltha()##twaslaasdzy] [it gives you exactly] [what you asked] [for.png] [damn] [nic ehuh.png ]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);