import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{12,13}(\\t| ){1,}\\d{1,9}$";
final String string = "5907587146563 5\n"
+ "5907587146761 5\n"
+ "5,9077553218 5\n"
+ "5907755321983 5d\n"
+ "5,907755322 5\n"
+ "5907755323062 562332322\n"
+ "5907755356700 533223233\n"
+ "5907755356745 3\n"
+ "5907755371575 5\n"
+ "5907587155169 8\n\n"
+ "5901905310162 20\n"
+ "5901905310161 12\n"
+ "5907587155244 1\n"
+ "12345678901234 14\n"
+ "1234567890123 13\n"
+ "123456789012 12\n"
+ "12345678901 11\n"
+ "1234567890 10\n"
+ "590758715524 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}