import re
regex = re.compile(r"^\d{12,13}(\t| ){1,}\d{1,9}$", flags=re.MULTILINE)
test_str = ("5907587146563 5\n"
"5907587146761 5\n"
"5,9077553218 5\n"
"5907755321983 5d\n"
"5,907755322 5\n"
"5907755323062 562332322\n"
"5907755356700 533223233\n"
"5907755356745 3\n"
"5907755371575 5\n"
"5907587155169 8\n\n"
"5901905310162 20\n"
"5901905310161 12\n"
"5907587155244 1\n"
"12345678901234 14\n"
"1234567890123 13\n"
"123456789012 12\n"
"12345678901 11\n"
"1234567890 10\n"
"590758715524 1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")