use strict;
my $str = '5907587146563 5
5907587146761 5
5,9077553218 5
5907755321983 5d
5,907755322 5
5907755323062 562332322
5907755356700 533223233
5907755356745 3
5907755371575 5
5907587155169 8
5901905310162 20
5901905310161 12
5907587155244 1
12345678901234 14
1234567890123 13
123456789012 12
12345678901 11
1234567890 10
590758715524 1';
my $regex = qr/^\d{12,13}(\t| ){1,}\d{1,9}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}