$re = '/^\d{12,13}(\t| ){1,}\d{1,9}$/m';
$str = '5907587146563 5
5907587146761 5
5,9077553218 5
5907755321983 5d
5,907755322 5
5907755323062 562332322
5907755356700 533223233
5907755356745 3
5907755371575 5
5907587155169 8
5901905310162 20
5901905310161 12
5907587155244 1
12345678901234 14
1234567890123 13
123456789012 12
12345678901 11
1234567890 10
590758715524 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);