#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:1234|@234|1@34|12@4|123@)"
Local $sString = "12345678" & @CRLF & _
"@2345678" & @CRLF & _
"1@345678" & @CRLF & _
"12@45678" & @CRLF & _
"123@5678" & @CRLF & _
"@@@@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")