$re = '/(?:1234|@234|1@34|12@4|123@)/m';
$str = '12345678
@2345678
1@345678
12@45678
123@5678
@@@@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);