const regex = /(?:1234|@234|1@34|12@4|123@)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:1234|@234|1@34|12@4|123@)', 'gm')
const str = `12345678
@2345678
1@345678
12@45678
123@5678
@@@@`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}