package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:1234|@234|1@34|12@4|123@)`)
var str = `12345678
@2345678
1@345678
12@45678
123@5678
@@@@`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}