#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)(?m)^HFT-(.+?)\h+.+$"
Local $sString = "HFT-COOL (Surf) - Codingweb" & @CRLF & _
"HFT-SURFER (Surf) - Codingweb"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)