using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^HFT-(.+?)\h+.+$";
string substitution = @"\1";
string input = @"HFT-COOL (Surf) - Codingweb
HFT-SURFER (Surf) - Codingweb";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}