#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:1,2|2,3|3,4|4,5|5,6)$"
Local $sString = "1,2" & @CRLF & _
"2,3" & @CRLF & _
"3,4" & @CRLF & _
"4,5" & @CRLF & _
"5,6" & @CRLF & _
"" & @CRLF & _
"1,1" & @CRLF & _
"2,4" & @CRLF & _
"4,6" & @CRLF & _
"7,8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")