// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:1,2|2,3|3,4|4,5|5,6)$").unwrap();
let string = "1,2
2,3
3,4
4,5
5,6
1,1
2,4
4,6
7,8";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}