$re = '/^(?:1,2|2,3|3,4|4,5|5,6)$/m';
$str = '1,2
2,3
3,4
4,5
5,6
1,1
2,4
4,6
7,8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);