using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:1,2|2,3|3,4|4,5|5,6)$";
string input = @"1,2
2,3
3,4
4,5
5,6
1,1
2,4
4,6
7,8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}