import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/)\\d{9}(?=]]$)";
final String string = "[[https://vimeo.com/channels/mercedesbenz/166551756]]\n"
+ "[[https://vimeo.com/153002910]]\n"
+ "[[https://vimeo.com/jp/channels/staffpicks/259634725]]\n"
+ "[[https://vimeo.com/jp/channels/staffpicks/46259634725]]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}