const regex = /(?<=\/)\d{9}(?=]]$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\/)\\d{9}(?=]]$)', 'gm')
const str = `[[https://vimeo.com/channels/mercedesbenz/166551756]]
[[https://vimeo.com/153002910]]
[[https://vimeo.com/jp/channels/staffpicks/259634725]]
[[https://vimeo.com/jp/channels/staffpicks/46259634725]]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}