use strict;
my $str = '[[https://vimeo.com/channels/mercedesbenz/166551756]]
[[https://vimeo.com/153002910]]
[[https://vimeo.com/jp/channels/staffpicks/259634725]]
[[https://vimeo.com/jp/channels/staffpicks/46259634725]]
';
my $regex = qr/(?<=\/)\d{9}(?=]]$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}