$re = '/(?<=\/)\d{9}(?=]]$)/m';
$str = '[[https://vimeo.com/channels/mercedesbenz/166551756]]
[[https://vimeo.com/153002910]]
[[https://vimeo.com/jp/channels/staffpicks/259634725]]
[[https://vimeo.com/jp/channels/staffpicks/46259634725]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);