using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<meta property=""og:image"" content="")http[:\/a-z0-9\.]+(?=""\/>)";
string input = @"<html>
<meta property=""og:image"" content=""http://img.xxx.xx/vid/xxx/b7950d611f934f0eef95c1cd010348e3.jpg""/>
</html>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}