$re = '/(?<=<meta property="og:image" content=")http[:\/a-z0-9\.]+(?="\/>)/';
$str = '<html>
<meta property="og:image" content="http://img.xxx.xx/vid/xxx/b7950d611f934f0eef95c1cd010348e3.jpg"/>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);