import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<meta property=\"og:image\" content=\")http[:\\/a-z0-9\\.]+(?=\"\\/>)";
final String string = "<html>\n"
+ "<meta property=\"og:image\" content=\"http://img.xxx.xx/vid/xxx/b7950d611f934f0eef95c1cd010348e3.jpg\"/>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}