re = /(?<=<meta property="og:image" content=")http[:\/a-z0-9\.]+(?="\/>)/
str = '<html>
<meta property="og:image" content="http://img.xxx.xx/vid/xxx/b7950d611f934f0eef95c1cd010348e3.jpg"/>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end