#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^\*{2}\ Reading\ -\ T.+[\n\r]" & @CRLF & _
"(?P<block>(?:(?!^\*{2})[\s\S])+)"
Local $sString = "** Hardware [0/1]" & @CRLF & _
" - [ ] adapt a programmable motor to a tripod to be used for panning " & @CRLF & _
"** Reading - Technology [1/6]" & @CRLF & _
" - [X] Introduction to Networking - Charles Severance" & @CRLF & _
" - [ ] A Tour of C++ - Bjarne Stroustrup" & @CRLF & _
" - [ ] C++ How to Program - Paul Deitel" & @CRLF & _
" - [X] Computer Systems - Randal Bryant" & @CRLF & _
" - [ ] The C programming language - Brian Kernighan" & @CRLF & _
" - [ ] Beginning Linux Programming -Matthew and Stones" & @CRLF & _
"** Reading - Health [3/4]" & @CRLF & _
" - [ ] Patrick McKeown - The Oxygen Advantage" & @CRLF & _
" - [X] Total Knee Health - Martin Koban" & @CRLF & _
" - [X] Supple Leopard - Kelly Starrett" & @CRLF & _
" - [X] Convict Conditioning 1 and 2 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")