# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^\*{2}\ Reading\ -\ T.+[\n\r]
(?P<block>(?:(?!^\*{2})[\s\S])+)
"""
test_str = ("** Hardware [0/1]\n"
" - [ ] adapt a programmable motor to a tripod to be used for panning \n"
"** Reading - Technology [1/6]\n"
" - [X] Introduction to Networking - Charles Severance\n"
" - [ ] A Tour of C++ - Bjarne Stroustrup\n"
" - [ ] C++ How to Program - Paul Deitel\n"
" - [X] Computer Systems - Randal Bryant\n"
" - [ ] The C programming language - Brian Kernighan\n"
" - [ ] Beginning Linux Programming -Matthew and Stones\n"
"** Reading - Health [3/4]\n"
" - [ ] Patrick McKeown - The Oxygen Advantage\n"
" - [X] Total Knee Health - Martin Koban\n"
" - [X] Supple Leopard - Kelly Starrett\n"
" - [X] Convict Conditioning 1 and 2 ")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.