import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*{2}\\ Reading\\ -\\ T.+[\\n\\r]\n"
+ "(?P<block>(?:(?!^\\*{2})[\\s\\S])+)";
final String string = "** Hardware [0/1]\n"
+ " - [ ] adapt a programmable motor to a tripod to be used for panning \n"
+ "** Reading - Technology [1/6]\n"
+ " - [X] Introduction to Networking - Charles Severance\n"
+ " - [ ] A Tour of C++ - Bjarne Stroustrup\n"
+ " - [ ] C++ How to Program - Paul Deitel\n"
+ " - [X] Computer Systems - Randal Bryant\n"
+ " - [ ] The C programming language - Brian Kernighan\n"
+ " - [ ] Beginning Linux Programming -Matthew and Stones\n"
+ "** Reading - Health [3/4]\n"
+ " - [ ] Patrick McKeown - The Oxygen Advantage\n"
+ " - [X] Total Knee Health - Martin Koban\n"
+ " - [X] Supple Leopard - Kelly Starrett\n"
+ " - [X] Convict Conditioning 1 and 2 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}