#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)rating-inbtn[^>]+>\s*([^\s<]+)\s*<\/"
Local $sString = "<span class="vote-actions">" & @CRLF & _
" <a class="btn btn-default vote-action-good">" & @CRLF & _
" <span class="icon thumb-up black black-hover"> </span>" & @CRLF & _
" <span class="rating-inbtn">215</span>" & @CRLF & _
" </a>" & @CRLF & _
" <a class="btn btn-default vote-action-bad">" & @CRLF & _
" <span class="icon thumb-down grey black-hover"> </span>" & @CRLF & _
" <span class="rating-inbtn">82</span>" & @CRLF & _
"<span class="rating-inbtn"> 74 </span>" & @CRLF & _
"<span class="rating-inbtn hide-if-zero-113"> 99 </span>" & @CRLF & _
" </a>" & @CRLF & _
"</span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")