using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"rating-inbtn[^>]+>\s*([^\s<]+)\s*<\/";
string input = @"<span class=""vote-actions"">
<a class=""btn btn-default vote-action-good"">
<span class=""icon thumb-up black black-hover""> </span>
<span class=""rating-inbtn"">215</span>
</a>
<a class=""btn btn-default vote-action-bad"">
<span class=""icon thumb-down grey black-hover""> </span>
<span class=""rating-inbtn"">82</span>
<span class=""rating-inbtn""> 74 </span>
<span class=""rating-inbtn hide-if-zero-113""> 99 </span>
</a>
</span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}